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fc:DataManager Quick Guide

Introduction

fc:DataManager is a comprehensive data cleaning toolset that enables
users to perform essential data operations on files with speed and
ease. fc:DataManager is the perfect choice for any business or
consultancy that needs to leverage the power of data for marketing,
stock control, customer communications, engineering and field support
... any activity where data has to be right, all the time.

This Quick Guide will help you to get started with the application. For a
detailed description of all the functions of the application, refer to the
main User Manual.

fc:DataManager allows you to

e Import data from delimited text files, Excel files and MS
Access files
(See Page 6 of this Quick Guide for details)

e Remove unwanted characters, trailing or leading spaces,
non-printable characters

e Correct capitalisation, upper/lower casing

e  Merge two files
(See Merging Data from Files in the main User Manual
for details)

e  Combine two files with different data structures
(See Combining Files in the main User Manual for
details)

e  Spilt or combine data in fields
(See Unwrapping/Extracting Records and
Wrapping/Combining Records in the main User Manual
for details)

e Match two files and exclude duplicate entries
(See Suppress Matching Records in the main User
Manual for details)

o Perform graphical analysis of populated fields
(See Page 15 of this Quick Guide for details)
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Installation

fc:DataManager can be installed via a CD or web link download. It has
two components: the application itself, and a MySQL database. Both
these components are supplied and are automatically loaded and
linked during the install process.

To install the fc:DataManager application:

If the application was obtained on a CD, insert the fc:DataManager CD
in your computer's CDROM and double-click
fcDataManagersetup.exe. If the application was downloaded, double-
click the extracted fcDataManagersetup.exe. The Installation wizard
opens and will take you through the installation process. Generally,
accept the options in the installation process and click the Next button
to continue the process.

In the last step of the installation process, click Install. The application
is set up on your machine.

Starting fc:DataManager
To start the application:

1. Click Start>Program Files>fc DataManager
->fc DataManager. The Signon dialogue opens.

2. Enter the Username and Password. When you start the
system for the first time, enter the user name and password of
your choice. You can also select a “Forgot Password”
guestion and enter an answer. The password is case-
sensitive. Note your choices and keep them secure: you
will need them for future access to the utility!

3. Select the Database and click OK. By default, the system
creates a database fcdemodb for you to get started. You can
create your own databases.

(See Page 5 of this Quick Guide for details)

Once you have successfully signed into the system, the main screen
appears.
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User Interface
The fc:DataManager user interface is shown below.
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The user interface lists any files that have been imported into the
system, showing their original names, their fc:DataManager names,
and other details such as date imported and number of records.

To sort the list in ascending/descending order of the selected
column, click on a column heading. To change the sort order, click the
heading again. To locate files in the list, select the search criteria and
enter a part of the name in the field provided.

Menu and Toolbar Buttons

The menu options and toolbar buttons available in the user interface
are summarised in the following table.

Button
File = Import Import a data file quickly
See Page 6 of this Quick Guide

Display file details, comments and history, and
set file permissions

See File History/Comments/Definition in the
main User Manual for details

(e

Comments/History
/Definition

Open file Display the selected file

See Page 9 of this Quick Guide

G

Copy file Copy the data in the selected file
See Copying a File in the main User Manual for

details

g

Delete the selected file
See Deleting a File in the main User Manual for
details

Delete file

Combine files Combine the data in two files

[
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Button
See Combining Files in the main User Manual
for details

Detailed Merge % Merge data from two files
See Merging Data from Files in the main User
Manual for details

Simple Merge E_EI See Merging Data from Files in the main User
Manual for details

Suppress matching E.:. Create a new file containing records that either

records exist only in the first file or exist in both files

See Suppressing Matching Records in the main
User Manual for details

Unwrap / extract —TELI Create a new file by splitting the records in the
records selected file
See Unwrapping/Extracting Records in the main
User Manual for details
Wrap / combine —TELI Create a file containing records that are
records combined from several records in the selected
file
See Wrapping/Combining Records in the main
User Manual for details
Database Create a new database
Maintenance — See Page 5 of this Quick Guide
Create Database
Change Database Change the current database
Delete Database Delete the current database
Security - Manage users
Usernames See Configuring Users in the main User Manual
for details
Set password Change password
See Page 5 of this Quick Guide
Authorise system Set authorisation code for system access
access See Authorising System Access in the main
User Manual for details
Exit ._j Close fc:DataManager
Windows Select an open window to view

See Switching Between Currently Open
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Name Toolbar Use
Button
Windows in the main User Manual for details

Help > Contents Opens the help system
About Display details about fc:DataManager

Changing the Password
To change your password:

1. Select the File>Security->Set Password option in the main
menu. The Change Password dialogue appears.

2. Enter the Current password and the New password.

Re-enter the new password in the second Confirm
Password field.

4, Select the question you want as the Password hint in case
the password is forgotten and enter the Answer to that
guestion.

5. Click H to save the password.

Creating a Database
To create a new database:

1. Click the File=»Database maintenance->Create database
menu option. The Create database dialogue opens as shown
in the figure below.

Create database

[Datahase name | Fo:Databasi ‘

2. Enter the name for the database and click Ok. The new
database is created and the opens. The files you now import
will be saved in this database.
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Importing a Data File

fc:DataManager operates on data saved in .csv (text delimited),
MsExcel (.xIs) or MsAccess (.mdb) files. MsExcel files that are
password-protected must be saved without a password before they are
imported into the system.

Files can be imported in one of the following ways:

Using simple import — This is a simple import operation
where the user selects a file and starts the import
process.

Mapping the import fields to existing fields - This enables
fc:DataManager’s automated features. For example,
mapping a full name will separate the first and last names
and copy the initials into a separate field.

Extended Import — This method can be used when the
above import methods fail. In this method the contents of
the file are read cell by cell thus making the process
slower than the other two methods. This method works
only with .csv files. See Importing a Data File in the main
User Manual for details

To import afile using the simple import process:

1. Click File=>Import or click the < toolbar button. The Import
file dialogue appears as shown below

Quick Import

File to Import  |E:\GisleniFe DataManageriDemo File 1 - Inpuk Mapped.csy =]

Advanced options

Field mapping mode {Advanced)

Use previous mapping |:|

2. Click the E option and select the required file in the Select
file to import dialogue that opens. Click Open.
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7.

For a simple import, clear the Field mapping mode
(Advanced) check box and click Next.

Specify the Column delimiter of the source file by selecting
the appropriate option. If the delimiter is not a comma, tab or
semicolon, select the Others option and enter the delimiter in
the space provided. The data in the first 100 records of the file
is displayed.

If the first row of the import file contains the column headers,
select the First row has column names check box.

If any of the data is enclosed in quotes, select the appropriate
Text Qualifier.

Select the Row delimiter.

To customise the data import process to match your needs,
click the Settings button. The Import Settings dialogue opens. The
dialogue has tabs in which you can set options for Titles, Address,
Names and Telephone format. See Setting the Import Process
Options in the main User Manual for details.

The internal database structure has pre-defined fields such as
Title, Salutation, First name, Last name, etc. The database has 60
additional text fields that can contain any type of data.

Click Next to proceed with the import. Enter or select a name for
the import file and click the Import button in the final screen of the
Quick Import wizard. The file is imported into the system based on
the settings configured in the earlier steps.

Quick Import

File details

Irmpart file Dema File 1 - Input Mapped.csy
File size: 4727 KB
Import to Demo File 1 - Input Mapped b

To import a file using the extended import process:

1.
2.

Repeat steps 1 and 2 as detailed in the previous section.

Select the Field mapping mode (Advanced) check box. You
can do one of the following:
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e Use mappings from a previous import — select the Use
previous mapping check box and select the required
import in the drop-down list

¢ Define mappings for this import - — select the database
fields into which you want to import the data. To define
the mapping for the import, clear the Use previous
mapping check box.

3. Click Next. The page in which you can define the mappings
appears as shown below.

Quick Import E\
File Info
Impart file Demo File 1 - Input Mapped  csv m
Nurnber of fields & [ Add unmapped ] [ Clearall mappings ” Clear mapping ]
Advanced mapping
Nurnber Database field |Impn|l hield ~

B Name Flag

L Shaortname
| » Company hame Title el Title:
| * Add Line il
| ¥ add Line | Firstnam
L2 EEI2E) | Last name
| ¥ Post Code |

Il namne ame
Map the fleldS from (Campany nal Zompany Mame
the import file Address line 1 dd Line 1
N p Address line 2 dd Ling 2

using the dl’ag'and- [Address line 3 Add Line 3

d rop ope ration Address line 4 v

File comment{note

[ << Back ][ et =3 ] [ Cancel ]

The left panel of the page contains the fields in the import file and
the right panel the mappings. The first column in the right panel
displays the fields in the internal database and the second column

the imported fields.
To clear all existing mappings, click Clear all mappings.

To clear a specific mapping, select it in the right panel and click
Clear mapping.
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To map the fields, click on a field in the left panel and use the

drag-and-drop operation to map it to the appropriate Import field
cell.

4. Enter any comment/note (optional) for the file.

5. Click Next. In next screen of the Import file wizard configure
the import process options. See Setting the Import Process
Options in the main User Manual for details.

Once you have configured the process options, click Next and then
click the Import button in the page that opens. The file is imported into
the system based on the settings configured in the earlier steps.

Opening a File
To open a file, select the file in the fc:DataManager main window and

click the File=>Open File menu option or the = toolbar button.
Alternatively, double-click the file in the list. The file details are
displayed in a new window as shown below.

Demo File 1 - Input Mapped

Fin Edt Vew Hep

O~ =DM FRNENRC® R Sl coie @ FERET won
[ Showeme | JobTEe | Itid | Fiwrame | Lewreme | Home | Sostn | Comporyome | Addlmel a
PUBLICIS Mansgng Diestor A A Tuboch M A Tuoch Mr Tuboch PUBLICIS LTD ... Kings House
TEQURANLOND... Pescorrel Offcer G G Linseraon MiG Cloweraon  Milowerior  TEQUIRAWOND.. NothGae
CHELWOOD Proctice Manager & 5 Andetson Mrs§Ardeson  MrsAndemon  CHELWODOD TR.. Kidieglon
CoP Tosmng s J John Grark Jok Grart M Grant COP TRAMIS 5U... Ricthesfisd Greys
FLAG Group Account Di J John Hurter MeJobriHumtee Mt Hundes FLAG TELECOM . Bowater House

o

WEBPLACING Chaseman Dente. bl Mrs Derise Bl Mrs Bl WEBPLADNG Peserbarcugh

The menu options and toolbar buttons available in the file window are
summarised in the following table.

Name Toolbar Use
Button

File->Copy data to Copy data in file to clipboard

clipboard See Copying Data in a File to the Clipboard
in the main User Manual for details

Copy file w Copy data in file to a new file

See Copying Data to a New File in the
main User Manual for details

Copy to Excel Copy data in file to an Excel file

Export Export data to a .csv file
See Page 11 of this Quick Guide
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Autobackup

Close

Edit=>Cells

Record

Find record

New record

Delete record

Undelete record

Update data

Clean data

De-duplicate

View—->Select columns

Filter record

Statistics

O

't

9

a
o

@

Quick Guide

Use

Create cross-table analysis
See Creating Cross-Table Analysis in the
main User Manual for details

Set auto backup options
See Setting the Automatic Backup Options
in the main User Manual for details

Exit the file display

Edit the data in cells directly

Edit data in entire record (in new window)
See Page 12 of this Quick Guide

Search record (with replace option)
See Searching for Data in a File in the main
User Manual for details

Create a new record
See Page 12 of this Quick Guide

Flag selected record or all records as
deleted

Clear delete flag for selected record or all
records

Update data in record
See Updating Data in a File in the main
User Manual for details

Clean data in record
See Page 15 of this Quick Guide

Check and remove duplicate data
See Page 13 of this Quick Guide

Select the columns for display
See Setting Columns for Display in the
main User Manual for details

Filter records based on a query
See Setting a Query Filter in the main User
Manual for details

View the chart and analysis of data in file
See Page 15 of this Quick Guide
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Name Toolbar Use
Button
Record count View the number of records in the file

See Viewing the Number of Records in a
File in the main User Manual for details

Refresh list d Refresh data in grid

Sort data §+ Sort data in ascending or descending order
of the selected columns.

View buttons Toggle view of toolbar buttons in the
window

All records Select an option to view the required
recor

Not deleted ecords

Deleted only

Match count=0
Match count=1

Multiple matches

Exporting Data to a New File
To export selected data from the current file to a new file:
1. Open the required file and click the File>Export on the menu

or the toolbar button. The Export options dialogue
appears as shown in the figure on the next page.

To set the fields to export, ensure the Select fields check box is
selected.

To set where the data will be exported, enter or select a
filename. The filename must have a .csv extension.
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Export options g|
[1R"4
Select fields

Expart to filename I'E:\Gislen'Fc Datah anagerFile 4 - Merge File B.osy” ﬂ

Field separatar - [ [OTab Text qualifier | v
All records ®
Range O

From record ﬁ

Tarecord a

Enter the Field Separator. If the field separator is a TAB, select
the Tab check box.

If the text in the file uses a Text qualifier, select it in the drop-
down list. Select “none” if there is no text qualifier in the file.

To export all the records in the current file, select the All
records option. To export a range of records, select the Range

option and then enter or use the controls provided to select the
range.

2. Click %" If you have selected to set the fields for export, the
Set Columns dialogue is displayed. The selected data is
exported to the new file and a message appears.

Click [| or .23 to close the Export options dialogue.

Adding/Editing Records

You can add a new record, or edit records in the currently open file.
To add arecord:

1. Open the required file and click the Edit<>New record menu

option or the O toolbar button. The Record view dialogue
appears.

2. Enter the data for the fields in the record. Press ENTER to
navigate to the next cell.
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3. Click H to save the new record. The new record appears in
the grid.

To edit the data in a record, select the record and click Edit=>Record

on the menu or the El toolbar button. Make the required changes and
click .
To delete a record, select it in the file display and click the

Edit->Delete record menu option or the =% toolbar button. The system
prompts you to select if you want to set the delete flag for all the
records in the current file or for the selected record.

A "D" appears in the Flag column for the record. If the Flag field is not
visible, use the View->Select columns option.
See Setting Columns for Display in the main User Manual for details.

The flagged records will be permanently deleted after confirmation
when you close the file view.

To remove the delete flag set for a record, open the file and click the

Edit>Undelete record menu option or the |~ toolbar button. Make
your choice in the message prompt displayed.

Removing Duplicate Data from a File

The De-duplicate function of fc:DataManager allows you to remove
duplicate data from an existing file.

To de-duplicate data:
1. Open the required file and click the Edit-<>De-duplicate menu

option or the @ toolbar button. The De-Duplicate dialogue
appears as shown below.

=

A e = B By 5% B8 ol roces v [ ) dgheste mconds v ——
Sebect fiekds b check r
] gnose blank. fiekds R
— _— = To work on dl,_lpllcate
Comeelisne ) Comttch 8 L records, highlight them
3 3 = and then click the

[Mumbes  [Mame  [JobTile  |Comparw M. s Line 1 [AddLine 2 3] magnifying icon

4% ] 50N i r RN LT ] o House TlTGm A TSS

m MiA Trby Propeetor  ARRNA TRAMNE NORTHERN LTD 25 St Martiee ook SAITD
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2. Select the fields you want to check for duplicates and the
criteria to use in the drop-down boxes provided in the Select

fields to check panel and then click 47 . The duplicate fields
are displayed in a grid in the lower portion of the dialogue as
shown in the above figure.

The records that appear to be duplicates can be isolated and
worked on. Highlight the duplicate records by pressing the Shift

key while you click on them and click the option. Add records,
move data from other records or delete duplicate records in the
Details window.

To update the data in a particular field, select the Field and
enter the appropriate value in the To value fields located in the

Update panel and click EI.

To clear the data in the selected field, leave the To value field
blank. You can select multiple fields to update.

To add a new field, click the button. In the File details
dialogue, scroll down the list and enter the name of the new field in
any of the free Additional fields. Save the new field.

To select the records you want to view, use the Show panel at
the top of the De-Duplicate dialogue. You can select view ‘all’,

‘deleted’, ‘duplicate’ or ‘unique’ records. The number of records
displayed in the grid is indicated adjacent to the Show panel.

To flag a record for deletion, select the record in the grid and

click €% The Flag field for the selected record/all records, based
on your choice, is set to "D", The flagged records will be
permanently deleted after confirmation when you close the file
view.
To clear the delete flag for a record, select the record in the grid
and click [<".

o i
To export the data to a .csv file, click the button. See
Exporting Data to a New File on page 11 of this Quick Guide for
details.

Click 1 to exit the dialogue.
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Cleaning the Data in a File

You can clean data in the currently open file — remove blank spaces,
non-numeric or non-alphabetic characters, change case, and so on.
You can also set values to fields in the file.

To clean data:
1. Open the required file, select a column in the grid and click

the Edit->Clean data menu option or the 4 toolbar button.
The Clean data field dialogue appears as shown below.

Clean data field

0~
Diata field

tethod Femove blank spaces -

Pt rasult inko fisld Job Title v

Select the Data field you want to clean.

Select the Method. Refer to the main User Manual for an
explanation of the available methods.

4. Select the field into which you want to place the result of the
clean operation in the Put result into field drop-down.

To place the cleaned data into a new field, click the D putton.

In the File details dialogue, scroll down the list, enter the name of

the new field in any of the free Additional fields and click the H
button to save the new field.

Once you have configured the clean operation, click ¥". A message

appears. Click Yes to update all records and No to update only the
current record.

Click ¥l to exit the dialogue without saving the changes.

Viewing the Statistics

You can view a graph of how populated a field is and the detailed
analysis for each field in the file.
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To view the statistics:
1. Open the required file and click the View=>Statistics menu

option or the { toolbar button. The Statistics dialogue opens
as shown below.

EEX

¥ 526 records Paints per page || & Page 1 Aot 1

Chart analysis | Detail analysis

Percentage data fill for Demao File 1 - Input Mapped

Add Line 1
Add Line 3
Post Code

Company Name

2. The graph in the Chart analysis tab indicates the percentage
of data filled in each field in the file. The number of records in
the file is displayed on the top of the dialogue.

To view the details for a particular field, click the bar for that
field. The Data Analysis dialogue appears. The dialogue has
options to view a pie chart, bar chart, legends and set filter
gueries. See Data Analysis in the main User Manual for details

To view the detailed analysis for each field, click the Detail
analysis tab. The number of records containing data and the
percentage for each field in the file is displayed.

To view the details for a particular field, click the appropriate
2 option for that field. The Data Analysis dialogue appears.
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To copy the chart to the clipboard so that it can be pasted
into any application, click =)
To close the Statistics dialogue, click E

To view the analysis of data in the file, click the bar for that field. The
Data Analysis dialogue appears as shown in the following figure.

Data analysis
[l & {i a’é’ Select where the count is «
Paints per page |20 E Page of 26 Sort by | Field value v Count; 512

Number

28
26
24
22

18
16
14
12

k]
06
04
0z

'l:’] Tip: If the bar chart looks compressed, position your mouse on
the corner of the dialogue and use the double arrow handle to
adjust the size of the dialogue.

The Data analysis dialogue displays the number of entries in the
selected field. Each unique entry is allotted a separate colour.

To set the selection type, click ﬁ. In the Set field setting
dialogue that appears, do one of the following:

e Calculate on whole field - analyse on the whole field

e Calculate on first 'x' characters - analyse on the specified
number of characters taken from the beginning of the
field
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To exclude blank records from the analysis, select the Exclude
blank records check box. Click OK to start the analysis. The chart
is refreshed according to the result of the specified analysis.

To view a shortcut menu, right-click on a bar in the graph and
select an option in the shortcut menu displayed.

To set the filter query on the selected field, click Set filter on:
<entry>, where <entry> is the value in the field.

To add the selected field to the select or exclude filter query,
click the apropriate Add <entry> to filter option in the right-click
shortcut menu.

To select to view records based on the count, first select the
option in the Select where the count is drop-down, then enter the

number or use the controls to set the number and click + .

Click [| to close the Data Analysis dialogue.

Merging Data from Files

You can take data from two files and merge it into a new file. There
are two types of merge: simple and detailed. This manual explains
the simple merge process. Refer the main User Manual for the
Detailed Merge process

To merge data from different files using the simple merge:

1. Select one of the files you want to merge in the file list on the
main window of the application and then select the

File=>Simple Merge menu option or click the E_EI toolbar
button. The Simple merge dialogue appears as shown below.

Simple merge
==

File A: _Demo File 3 - Merge File & b
Fila B:

2. Without closing the dialogue, go back to the main window and
double-click the second file you want to merge from the list.
The second file is added to the dialogue as File B.

If you want to delete any of the selected files, click the

appropriate button.
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3. To continue with the merge, click the E_EI button. The Simple
merge wizard opens as shown in the following figure.

Simple merge EJ@E'
S

File A Dema Fie 3 - Merge File &

File B: DemaFie 4 - Merge File B

Select records
(3 Only select matching records
© Select all records from file (4)
) Select all records from file [B)
Select fields to match:
A: Dema File 3- Merge File & B: Demo File 4 - Merge Fie B
« || Exact match | Mumber -

v v v v

v v v v

4. Select the records you want to merge. In the Select records
panel, you can select all records from file A or file B, or select
only matching records.

5. Select the fields you want to match from File A and File B,
and the matching method using the drop-down boxes
provided. You can select up to 3 criteria for the matches. For
multiple criteria, use the bracket ["(" and ")"] options and
logical options [and, or] available in the drop-down boxes at
the start and end of each row in the above dialogue.

6. Once you have defined the match, click the # button. The
next screen in the simple merge wizard appears as shown in
the figure on the next page.

7. The left panel displays the Fields from (A) and the right panel
the Fields from (B). The middle panel Merged file fields
displays the mappings. The merge process creates a new file
and the selections displayed in the middle panel indicate the
layout of the new file. The first column in the middle panel
displays the internal database fields and the second column
the Use field.

8. To map fields from File A and File B, drag-and-drop the
required fields from the left and right panels to the appropriate
Use field cells.
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Simple merge

<>
File & Denoiae s ia
File B Demo File 4 - Merge File B

Fields from (4)

Merged file fields
Dema File 3 - Merge File &

Ficlds from (8)
Dema File 4 - Meige File B

Past Code

alulation 4 Salutation
Job bHE &.Job Title
Company name

ompany Nam

Map the fields from Si::t:::;
the files using the = e
drag-and-drop

Operation B.Post Code_

Data field Use field [~ Flag
Numbst Nurbst
Shortname Shortname: £ Shortname: addLie 1
Tille Title A Titke £ddLine 2
Intial nitial Alnitial Add Line 3
Firstname
L net rame® Eistname # Firstname Mohme
E\Ialme Last name: ast name

alutation
s Full hame A Name

v

To clear the mapping in any cell, click in the cell, select the
text and press DELETE or BACKSPACE on your keyboard.

Click the # button to continue the merge process. The final
screen of the wizard appears in which you need to enter the
filename and Description (optional) for the new file and click
Merge files. A message indicating the end of the merge
process appears.

Click the [| button to exit the merge process. The new file appears in
the file list on the main window of the application.

Closing fc:DataManager
To close the application:

Click the 4 or I button on the main window of the application.
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